activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Hammer (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (AMQ-6521) compatibility issue with jetty 9.3.11 in org.apache.activemq.transport.http.HttpTransportServer
Date Fri, 09 Dec 2016 13:58:58 GMT

     [ https://issues.apache.org/jira/browse/AMQ-6521?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Carsten Hammer reopened AMQ-6521:
---------------------------------

I am sorry that I did not find this earlier, but it is very difficult for me to push snapshot
versions into my test environment

> compatibility issue with jetty 9.3.11 in org.apache.activemq.transport.http.HttpTransportServer
> -----------------------------------------------------------------------------------------------
>
>                 Key: AMQ-6521
>                 URL: https://issues.apache.org/jira/browse/AMQ-6521
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.14.1
>            Reporter: Carsten Hammer
>            Assignee: Christopher L. Shannon
>            Priority: Minor
>             Fix For: 5.15.0, 5.14.2
>
>
> There is a instantiation of a class that does not exists, see org.apache.activemq.transport.http.HttpTransportServer.java:
>  private void addGzipHandler(ServletContextHandler contextHandler) throws Exception {
>         Handler handler = new GzipHandler();
>         contextHandler.setHandler(handler);
>     }
> org.eclipse.jetty.servlets.gzip.GzipHandler does not exist. Instead there is a class
org.eclipse.jetty.server.handler.gzip.GzipHandler.java
> in https://mvnrepository.com/artifact/org.eclipse.jetty/jetty-server/9.3.13.v20161014
> Because of this activemq is not compatible with jetty versions since 9.0



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message