activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-6506) OSGi import ranges for javax.jms should include version 2.0 for activemq-jms-pool
Date Tue, 22 Nov 2016 18:45:59 GMT

    [ https://issues.apache.org/jira/browse/AMQ-6506?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15687534#comment-15687534
] 

ASF subversion and git services commented on AMQ-6506:
------------------------------------------------------

Commit 2a56c6037df60f2adec18c1184ace3b25dd00f98 in activemq's branch refs/heads/master from
[~graben]
[ https://git-wip-us.apache.org/repos/asf?p=activemq.git;h=2a56c60 ]

AMQ-6506: Increase OSGi version range for package import javax.jms


> OSGi import ranges for javax.jms should include version 2.0 for activemq-jms-pool
> ---------------------------------------------------------------------------------
>
>                 Key: AMQ-6506
>                 URL: https://issues.apache.org/jira/browse/AMQ-6506
>             Project: ActiveMQ
>          Issue Type: Improvement
>          Components: activemq-pool
>    Affects Versions: 5.14.1
>            Reporter: Benjamin Graf
>            Assignee: Gary Tully
>            Priority: Minor
>             Fix For: 5.15.0
>
>
> The import ranges for the ActiveMQ JMS pool bundle should allow, not exclude version
2.0 of the javax.jms API, since JMS 2.0 is backwards compatible with 1.1.  
> Should be like in activemq-osgi
> javax.jms;version=[1.1,3)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message