activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARTEMIS-750) Artemis Windows Service Fails to Start
Date Tue, 04 Oct 2016 19:20:21 GMT

    [ https://issues.apache.org/jira/browse/ARTEMIS-750?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15546376#comment-15546376
] 

ASF subversion and git services commented on ARTEMIS-750:
---------------------------------------------------------

Commit 1f3dcf28719ee967e2eabbd9ac146c718ed89dfe in activemq-artemis's branch refs/heads/master
from jbertram
[ https://git-wip-us.apache.org/repos/asf?p=activemq-artemis.git;h=1f3dcf2 ]

ARTEMIS-750 use JAVA_HOME for Win service


> Artemis Windows Service Fails to Start
> --------------------------------------
>
>                 Key: ARTEMIS-750
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-750
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 1.4.0
>         Environment: Windows 10 Anniversary Edition, 64-bit
>            Reporter: Jim Gomes
>            Assignee: Justin Bertram
>            Priority: Blocker
>              Labels: service, windows
>             Fix For: 1.5.0
>
>         Attachments: errorstartingservice-screenshot.png
>
>
> After installing Artemis as a service successfully using the following command-line:
> {{artemis-service install}}
> the service returns an error when I try to start it.
> # Go to the Services control panel
> # select the Artemis service entry
> # right click to bring up the context menu
> # click the Start menu item.
> It looks like it tries to start, but then an error dialog is displayed (see attached
image).  When the service error log is checked, no error is logged. The following is logged:
> {noformat}
> 2016-09-23 12:53:32 - Starting java  "-Xbootclasspath/a:C:\Program Files\Apache\apache-artemis-1.4.0\lib\jboss-logmanager-2.0.3.Final.jar"
-XX:+UseParallelGC -XX:+AggressiveOpts -XX:+UseFastAccessorMethods -Xms512M -Xmx1024M -classpath
"C:\Program Files\Apache\apache-artemis-1.4.0\lib\artemis-boot.jar" "-Dartemis.home=C:\Program
Files\Apache\apache-artemis-1.4.0" -Dartemis.instance=C:\ProgramData\Apache\AMQ -Djava.util.logging.manager=org.jboss.logmanager.LogManager
-Dlogging.configuration=file:C:\ProgramData\Apache\AMQ\etc\logging.properties -Djava.security.auth.login.config=C:\ProgramData\Apache\AMQ\etc\login.config
org.apache.activemq.artemis.boot.Artemis run
> 2016-09-23 12:53:32 - Started 2576
> {noformat}
> When launched from the command-line (not using the service wrapper), Artemis will launch
and run just fine.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message