activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher L. Shannon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-6430) noLocal=true in durable subscriptions is ignored after reconnect
Date Wed, 21 Sep 2016 12:49:20 GMT

    [ https://issues.apache.org/jira/browse/AMQ-6430?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15509813#comment-15509813
] 

Christopher L. Shannon commented on AMQ-6430:
---------------------------------------------

Looks like there are two places where the NoLocal attribute needs to be checked, it is done
in one location but not the other.

> noLocal=true in durable subscriptions is ignored after reconnect
> ----------------------------------------------------------------
>
>                 Key: AMQ-6430
>                 URL: https://issues.apache.org/jira/browse/AMQ-6430
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.13.4, 5.14.0
>         Environment: Ubuntu 14.04, OpenJDK 1.7.0_111 and Oracle JDK 1.8.0.74, other environments
not testet
>            Reporter: Daniel Faber
>            Assignee: Christopher L. Shannon
>         Attachments: ActiveMQNoLocalTest.java, pom.xml
>
>
> I create a connection to my local ActiveMQ and open two sessions. In the first session
I create a durable topic subscriber with noLocal=true. In the second session I send a message
to the same topic. Then I close both sessions and the connection. The first time I do this,
everything works well, that means I send but do not receive the message. The second time I
run the same application I send AND receive the message.
> After removing all files and directories in ActiveMQ's data directory, not receiving
my own message works again, but only once.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message