activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARTEMIS-659) Replace non-geronimo specs w/ geronimo equivalents.
Date Mon, 01 Aug 2016 02:26:20 GMT

    [ https://issues.apache.org/jira/browse/ARTEMIS-659?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15401452#comment-15401452
] 

ASF GitHub Bot commented on ARTEMIS-659:
----------------------------------------

Github user johnament commented on a diff in the pull request:

    https://github.com/apache/activemq-artemis/pull/691#discussion_r72918082
  
    --- Diff: pom.xml ---
    @@ -349,16 +349,9 @@
     
              <!-- Required for: JMS Injection -->
              <dependency>
    -            <groupId>javax.enterprise</groupId>
    -            <artifactId>cdi-api</artifactId>
    -            <version>1.2</version>
    -            <!-- License: Apache 2.0 -->
    -         </dependency>
    -         <dependency>
    -            <groupId>javax.inject</groupId>
    -            <artifactId>javax.inject</artifactId>
    -            <version>1</version>
    -            <!-- License: Apache 2.0 -->
    +            <groupId>org.apache.geronimo.specs</groupId>
    +            <artifactId>geronimo-atinject_1.0_spec</artifactId>
    +            <version>1.0</version>
    --- End diff --
    
    This may not even be needed.


> Replace non-geronimo specs w/ geronimo equivalents.
> ---------------------------------------------------
>
>                 Key: ARTEMIS-659
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-659
>             Project: ActiveMQ Artemis
>          Issue Type: Task
>            Reporter: John D. Ament
>             Fix For: 1.4.0
>
>
> The dependencies for java.inject and cdi-api are using the RI versions.  Should be the
geronimo versions.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message