activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Angelo Atanasov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-6367) Queues are not persisted after broker restart when using different persistence from KahaDB
Date Fri, 22 Jul 2016 15:57:20 GMT

    [ https://issues.apache.org/jira/browse/AMQ-6367?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15389733#comment-15389733
] 

Angelo Atanasov commented on AMQ-6367:
--------------------------------------

The problem from the link looks similar to the one that I experienced. Thanks for the link.

> Queues are not persisted after broker restart when using different persistence from KahaDB
> ------------------------------------------------------------------------------------------
>
>                 Key: AMQ-6367
>                 URL: https://issues.apache.org/jira/browse/AMQ-6367
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker, JDBC, KahaDB
>    Affects Versions: 5.11.2
>         Environment: Fedora 22, 64bit
>            Reporter: Angelo Atanasov
>
> Steps to reproduce:
> 1. Set a postgres jdbcPersistenceAdapter :
> ---
>  <persistenceAdapter>
>         <!-- disable kahaDB persistence -->
>         <!--    <kahaDB directory="${activemq.data}/kahadb"/> -->
>                 <jdbcPersistenceAdapter dataDirectory="${activemq.base}/activemq-data"
dataSource="#postgres-ds" createTablesOnStartup="true"/>
>         </persistenceAdapter>
>  ---
> <bean id="postgres-ds" class="org.postgresql.ds.PGPoolingDataSource" destroy-method="close">
>         <property name="serverName" value="localhost"/>
>         <property name="databaseName" value="activemqdb"/>
>         <property name="portNumber" value="0"/>
>         <property name="user" value="postgres"/>
>         <property name="password" value="abcdef123"/>
>         <property name="dataSourceName" value="postgres"/>
>         <property name="initialConnections" value="1"/>
>         <property name="maxConnections" value="10"/>
>     </bean>
> 2. Start the broker
> 3. Go to http://localhost:8161/admin/queues.jsp
> 4. Create manually a queue with some name
> 5. The queue has been created and listed
> 6. Restart the broker  (./activemq restart)
> 7. Go back to http://localhost:8161/admin/queues.jsp
> 8. The queue disappeared!
> Expected behavior:
> At point 8. The queue should be listed even after a restart.
> ------------------------------
> When we using the kahaDB persistence there is no such issue. It seems that this only
happens when we're using external database persistence such as postgres



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message