activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher L. Shannon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-6230) Camel 2.17.0 breaks Karaf integration tests
Date Tue, 12 Jul 2016 16:49:20 GMT

    [ https://issues.apache.org/jira/browse/AMQ-6230?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15373213#comment-15373213
] 

Christopher L. Shannon commented on AMQ-6230:
---------------------------------------------

I reverted back to Camel 2.16.x for now in master.  We most likely just need to skip 2.17
and wait for 2.18 because of the incompatibilities with OSGI.

> Camel 2.17.0 breaks Karaf integration tests
> -------------------------------------------
>
>                 Key: AMQ-6230
>                 URL: https://issues.apache.org/jira/browse/AMQ-6230
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: activemq-camel
>    Affects Versions: 5.13.2
>            Reporter: Christopher L. Shannon
>            Assignee: Claus Ibsen
>             Fix For: 5.14.0
>
>
> The new Camel version seems to cause the ActiveMQBrokerNdCamelFeatureTest test to fail.
> https://builds.apache.org/view/A/view/ActiveMQ/job/ActiveMQ-Java8/lastBuild/org.apache.activemq$activemq-karaf-itest/testReport/org.apache.activemq.karaf.itest/ActiveMQBrokerNdCamelFeatureTest/test/
> It looks like a bunch of work was done with Karaf and to get rid of Spring DM in the
new version which is probably the issue as ActiveMQ still has the Spring DM stuff laying around.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message