activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrei N.Sobchuck (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-6243) Wrong StorePercentUsage in leveldb replicas
Date Tue, 12 Apr 2016 08:13:25 GMT

     [ https://issues.apache.org/jira/browse/AMQ-6243?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrei N.Sobchuck updated AMQ-6243:
-----------------------------------
    Attachment: ActiveMQ-lvlDB_withoutAPP.zip

We created JMeter test case to reproduce the issue. 

> Wrong StorePercentUsage in leveldb replicas
> -------------------------------------------
>
>                 Key: AMQ-6243
>                 URL: https://issues.apache.org/jira/browse/AMQ-6243
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: activemq-leveldb-store
>    Affects Versions: 5.13.2
>         Environment: Solaris
>            Reporter: Andrei N.Sobchuck
>         Attachments: ActiveMQ-lvlDB_withoutAPP.zip
>
>
> We are trying to migrate to leveldb cluster with one master and two replicas.
> We faced with situation when 'store percent usage' is continously increasing on replicas
while it is staying normal on a master.
> Unlike AMQ-4810 we saw that real space is not consumed on replicas.
> After master is switched to a replica, the node still shows unreal 'store percent usage'.
We also had got situation when 'store percent usage' on replicas became bigger then 100%.
And after the master crashed and 'full' replica became new master, the new master did not
accept new messages because it was 'out of space'. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message