activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Tully (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-6199) cursorMemoryHighWaterMark configuration not applied to topic subscription
Date Tue, 08 Mar 2016 16:43:40 GMT

     [ https://issues.apache.org/jira/browse/AMQ-6199?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gary Tully updated AMQ-6199:
----------------------------
    Summary: cursorMemoryHighWaterMark configuration not applied to topic subscription  (was:
ursorMemoryHighWaterMark configuration not applied to topic subscription)

> cursorMemoryHighWaterMark configuration not applied to topic subscription
> -------------------------------------------------------------------------
>
>                 Key: AMQ-6199
>                 URL: https://issues.apache.org/jira/browse/AMQ-6199
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.13.0
>            Reporter: Gary Tully
>            Assignee: Gary Tully
>             Fix For: 5.14.0
>
>
> One can configure 
> {code:xml}
> <policyEntry topic=">" cursorMemoryHighWaterMark="10" />
> {code}
> but that cursorMemoryHighWaterMark is not set on the effective TopicSubscription. As
a result, topic messages don't get swapped to disk once the explicitly configured water mark
is reached.
> That should be a usage percentage of the systemUsage memory usage limit, but it stays
at the default 70 in error



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message