activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jamie goodyear (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-6176) Update Saxon version to 9.5.1-5_1
Date Fri, 19 Feb 2016 15:34:18 GMT

     [ https://issues.apache.org/jira/browse/AMQ-6176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jamie goodyear updated AMQ-6176:
--------------------------------
    Attachment: amq-5.13.x.patch

AMQ 5.13.x patch for Saxon update on 5.13.x branch.

> Update Saxon version to 9.5.1-5_1
> ---------------------------------
>
>                 Key: AMQ-6176
>                 URL: https://issues.apache.org/jira/browse/AMQ-6176
>             Project: ActiveMQ
>          Issue Type: Improvement
>    Affects Versions: 5.13.1, 5.14.0
>            Reporter: Jamie goodyear
>             Fix For: 5.14.0, 5.13.2
>
>         Attachments: amq-5.13.x.patch, amq-master.patch
>
>
> I had some Camel routes running embedded in the broker that were using xpath filters
and were throwing exceptions from Saxon until I upgraded the Saxon dependency. The exceptions
only occurred when running the broker with Java 8 but not Java 7.
> This is not the most recent version of the JAR. However, it is the earliest version where
the bug appears to be fixed (trying not to make too many changes at once).
> I'll supply patch files shortly.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message