activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erich Duda (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ARTEMIS-369) [Artemis Testsuite] BridgeFailoverTest#testFailoverOnBridgeNoRetryOnSameNode fails
Date Fri, 29 Jan 2016 12:36:40 GMT
Erich Duda created ARTEMIS-369:
----------------------------------

             Summary: [Artemis Testsuite] BridgeFailoverTest#testFailoverOnBridgeNoRetryOnSameNode
fails
                 Key: ARTEMIS-369
                 URL: https://issues.apache.org/jira/browse/ARTEMIS-369
             Project: ActiveMQ Artemis
          Issue Type: Bug
    Affects Versions: 1.1.0
            Reporter: Erich Duda


{code}
AMQ119007: Cannot connect to server(s). Tried with all available servers.
org.apache.activemq.artemis.api.core.ActiveMQNotConnectedException: AMQ119007: Cannot connect
to server(s). Tried with all available servers.
	at org.apache.activemq.artemis.core.client.impl.ServerLocatorImpl.createSessionFactory(ServerLocatorImpl.java:777)
	at org.apache.activemq.artemis.tests.integration.cluster.bridge.BridgeFailoverTest.internalTestFailoverOnBridge(BridgeFailoverTest.java:191)
	at org.apache.activemq.artemis.tests.integration.cluster.bridge.BridgeFailoverTest.testFailoverOnBridgeNoRetryOnSameNode(BridgeFailoverTest.java:96)
{code}

There is wrong wait condition. In the test we check if backup server started after failover,
but we should check whether backup server activated.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message