activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher L. Shannon (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMQ-5922) ActiveMQ OSGi metadata excludes compatibility with Spring 4.X
Date Mon, 21 Sep 2015 20:01:04 GMT

     [ https://issues.apache.org/jira/browse/AMQ-5922?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christopher L. Shannon resolved AMQ-5922.
-----------------------------------------
       Resolution: Fixed
    Fix Version/s: 5.13.0

PR applied with thanks

> ActiveMQ OSGi metadata excludes compatibility with Spring 4.X
> -------------------------------------------------------------
>
>                 Key: AMQ-5922
>                 URL: https://issues.apache.org/jira/browse/AMQ-5922
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: OSGi/Karaf
>    Affects Versions: 5.10.0
>            Reporter: Seth Leger
>            Assignee: Christopher L. Shannon
>            Priority: Critical
>              Labels: patch
>             Fix For: 5.13.0
>
>
> The OSGi metadata for ActiveMQ should be updated to include Spring 4.X in the version
range. Despite the fact that Spring no longer includes OSGi metadata in their own 4.X packages,
Apache Servicemix repackages Spring 4.X so that it can be used in OSGi containers like Apache
Karaf.
> This change is necessary in order for projects with Spring 4.X to coexist in the same
Apache Karaf container where ActiveMQ is running as a bundle/Karaf feature.
> This change has already been made in the activemq-camel submodule.
> I've submitted the change as a pull request on the github mirror of ActiveMQ: https://github.com/apache/activemq/pull/121



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message