activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chuck Rolke (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARTEMIS-207) [AMQP] Broker does not create session.
Date Fri, 21 Aug 2015 14:29:45 GMT

    [ https://issues.apache.org/jira/browse/ARTEMIS-207?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14706795#comment-14706795
] 

Chuck Rolke commented on ARTEMIS-207:
-------------------------------------

Another observation: if my AMQP.Net Lite client source provides a username and password then
while opening the connection the client includes a SASL negotiation exchange with the Artemis
broker. In that case the session is created properly and the client program succeeds.

This is not a fix but keep it in mind as a workaround until this issue is fixed.

> [AMQP] Broker does not create session.
> --------------------------------------
>
>                 Key: ARTEMIS-207
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-207
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>          Components: AMQP
>    Affects Versions: 1.0.0
>         Environment: apache-artemis-1.0.0-bin.tar.gz 14-aug-2015 broker
> AMQP.Net Lite client. hello world example
>            Reporter: Chuck Rolke
>
> The client sends: 
>  * init, open, begin, attach, attach.
> The broker responds with: 
>  * init, open, attach, attach
> The broker's begin to open the session is missing. And the attach frames from the broker
use handle 65535. The client closes the connection with an error
> {noformat}
>   Condition: amqp:not-found
>   Description: The session channel '65535' cannot be found.
> {noformat}
>  I tried single stepping my program to synchronize the steps but it still fails with
the same error.
> Trace: http://people.apache.org/~chug/artemis/20150819-1/artemis-helloworld-1.html



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message