activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Tully (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (AMQ-5917) networkConnectorStartAsync="true" results in "WARN | Could not connect to remote URI: ssl://... SSLContextImpl is not initialized" and failure to connect
Date Wed, 19 Aug 2015 15:08:45 GMT

    [ https://issues.apache.org/jira/browse/AMQ-5917?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14703154#comment-14703154
] 

Gary Tully edited comment on AMQ-5917 at 8/19/15 3:08 PM:
----------------------------------------------------------

more generally - we want to be able to specify the sslContext per networkConnector or transportConnector
- so they can be different.
For this case, having the networkConnectorStartExecutor thread factory set the thread local
with the brokers context via setCurrentSslContext for each thread it creates should do it.



was (Author: gtully):
more generally - we want to be able to specify the sslContext per networkConnector or transportConnector
- so they can be different.
For this case, having the networkConnectorStartExecutor thread factory set the thread local
with the brokers context should work.


> networkConnectorStartAsync="true" results in "WARN  | Could not connect to remote URI:
ssl://... SSLContextImpl is not initialized" and failure to connect
> ----------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMQ-5917
>                 URL: https://issues.apache.org/jira/browse/AMQ-5917
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.10.0, 5.11.1
>            Reporter: Gregg Saffell
>
> With both 5.10.0 and 5.11.1, the networkConnectorStartAsync="true" is broken for ssl.
 With two networkConnectors defined, only one connection is made and a warning is logged for
the other. 
> Snippets from my activemq.xml:
> <broker xmlns="http://activemq.apache.org/schema/core" ... networkConnectorStartAsync="true">

> ...
> <networkConnector name="GSTEST-96_ILSTECHNOLOGY_COM-SSO" uri="static:(ssl://172.27.11.96:5902)?useExponentialBackOff=false&amp;initialReconnectDelay=5000&amp;maxReconnectDelay=5000"
duplex="true" conduitSubscriptions="true" >
> ...
> networkConnector name="ECENTRESERVER_ILSTECHNOLOGY_COM-SSO" uri="static:(ssl://172.27.11.95:5902)?useExponentialBackOff=false&amp;initialReconnectDelay=5000&amp;maxReconnectDelay=5000"
duplex="true" conduitSubscriptions="true" >
> The specific warning that was generated is:
> 2015-08-05 10:46:31,569 | WARN  | Could not connect to remote URI: ssl://172.27.11.96:5902:
SSLContextImpl is not initialized | org.apache.activemq.network.DiscoveryNetworkConnector
| NetworkConnector Start Thread-0



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message