activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Lichtin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-5721) Update AMQ to commons-pool2
Date Mon, 24 Aug 2015 13:50:45 GMT

    [ https://issues.apache.org/jira/browse/AMQ-5721?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14709312#comment-14709312
] 

Martin Lichtin commented on AMQ-5721:
-------------------------------------

Has someone tried this change under OSGi?
Using 5.12.0 fails for me in this area with the new commons-pool2.

http://activemq.2283324.n4.nabble.com/OSGi-ClassNotFoundException-when-trying-to-upgrade-from-5-11-1-to-5-12-0-td4701124.html

I believe it may be fixed in version 2.4.1: https://issues.apache.org/jira/browse/POOL-292

> Update AMQ to commons-pool2
> ---------------------------
>
>                 Key: AMQ-5721
>                 URL: https://issues.apache.org/jira/browse/AMQ-5721
>             Project: ActiveMQ
>          Issue Type: Bug
>            Reporter: Jeff Genender
>            Assignee: Dejan Bosanac
>             Fix For: 5.12.0
>
>
> Update ActiveMQ to use commons-pool2 instead of commons-pool. AMQ-5636 will need it.
 The JMS pool and other components should use it as well.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message