activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clebert Suconic <clebert.suco...@gmail.com>
Subject Re: Message dropped from Queue
Date Mon, 20 May 2019 12:52:36 GMT
How are you creating the queue?


I would check the ./artemis data print, or artemis export to see what
happened to your journal.


Queues are not dropped unless you configured it to do so.


Check also the DLQ.. but the data print will probably help you find
where these messages are.

On Mon, May 20, 2019 at 7:27 AM dharmendra <dharmendra2u@gmail.com> wrote:
>
> Hi Team ,
>
> I am using Artemis 2.3.0 and using below broker.xml
> <?xml version='1.0'?>
>
> <configuration xmlns="urn:activemq"
>                xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>                xsi:schemaLocation="urn:activemq
> /schema/artemis-configuration.xsd">
>
>    <core xmlns="urn:activemq:core"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>          xsi:schemaLocation="urn:activemq:core ">
>
>       <name>0.0.0.0</name>
>
>       <persistence-enabled>true</persistence-enabled>
>
>
>       <journal-type>NIO</journal-type>
>
>       <paging-directory>/data/activemq-artemis/paging</paging-directory>
>
>
> <bindings-directory>/data/activemq-artemis/bindings</bindings-directory>
>
>       <journal-directory>/data/activemq-artemis/journal</journal-directory>
>
>
> <large-messages-directory>/data/activemq-artemis/large-messages</large-messages-directory>
>
>
>
>       <journal-min-files>10</journal-min-files>
>
>
>   <connectors>
>         <connector
> name="netty">tcp://${activemq.remoting.netty.host:jms.s1}:${activemq.remoting.netty.port:5445}?useEpoll=true</connector>
>         <connector
> name="netty-throughput">tcp://${activemq.remoting.netty.host:jms.s1}:${activemq.remoting.netty.port:5455}?useEpoll=true</connector>
>   </connectors>
>
>   <acceptors>
>         <acceptor name="netty"
> >tcp://${activemq.remoting.netty.host:jms.s1}:${activemq.remoting.netty.port:5445}?useEpoll=true</acceptor>
>         <acceptor name="netty-throughput"
> >tcp://${activemq.remoting.netty.host:jms.s1}:${activemq.remoting.netty.port:5455}?useEpoll=true</acceptor>
>   </acceptors>
>   <security-settings>
>     <security-setting match="#">
>       <permission type="createNonDurableQueue" roles="admin"/>
>       <permission type="deleteNonDurableQueue" roles="admin"/>
>       <permission type="createDurableQueue" roles="admin"/>
>       <permission type="deleteDurableQueue" roles="admin"/>
>       <permission type="createAddress" roles="admin"/>
>       <permission type="deleteAddress" roles="admin"/>
>       <permission type="consume" roles="admin"/>
>       <permission type="browse" roles="admin"/>
>       <permission type="send" roles="admin"/>
>       <permission type="manage" roles="admin"/>
>     </security-setting>
>   </security-settings>
>   <address-settings>
>     <address-setting match="#">
>       <dead-letter-address>jms.queue.DLQ</dead-letter-address>
>       <expiry-address>jms.queue.ExpiryQueue</expiry-address>
>       <redelivery-delay>0</redelivery-delay>
>       <max-size-bytes>10737418240</max-size-bytes>
>
> <message-counter-history-day-limit>10</message-counter-history-day-limit>
>       <address-full-policy>PAGE</address-full-policy>
>       <auto-create-queues>true</auto-create-queues>
>       <auto-create-addresses>true</auto-create-addresses>
>       <auto-create-jms-queues>false</auto-create-jms-queues>
>       <auto-create-jms-topics>false</auto-create-jms-topics>
>       <auto-delete-queues>false</auto-delete-queues>
>           </address-setting>
>   </address-settings>
>   </core>
> </configuration>
>
> We are getting some load ( for example 10k msg)from client into the Queue
> and approx 6k msg has been processed by consumer and but around 4 k msg is
> automatically dropper from this Q and consumer didn't find anything.  I
> checked logs and application logs but did n't find anything wiered but i am
> surprised that why this 4k msg has been automatically flush out from this Q.
> Please suggest me if any configuration missing in borker.xml or any other
> possibility . We migrated it from HornetQ and at that time it worked , no
> msg was dropped at that time. Please suggest any idea or configuration
> missing for this broker.xml.
>
>
>
> -----
> DKumar
> --
> Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-Dev-f2368404.html



-- 
Clebert Suconic

Mime
View raw message