activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robbie Gemmell <robbie.gemm...@gmail.com>
Subject Re: dist area clean up needed for old releases
Date Wed, 22 May 2019 15:09:49 GMT
Thanks for cleaning up the Apollo and Artemis bits Clebert (Artemis
2.7.0 can now go too, and 2.8.0 once 2.8.1 is on the site and
announced).

For ActiveMQ 5.14.5, I wouldnt consider it an active branch given its
age, the non trivial number of 5.15.x releases done since then without
any new 5.14.x, and multiple security fixes in 5.15.x that were not
backported. Noone has replied to suggest otherwise, so unless someone
does I will proceed to update the 5.14.5 release page on the website
tomorrow to point to the archive area, then ask again that a PMC
member clears it from the dist area.

Robbie

On Fri, 10 May 2019 at 20:27, Clebert Suconic <clebert.suconic@gmail.com> wrote:
>
> I have cross referenced with the other post about docs... I thought I
> was answering that post.
>
> However, since I accidentally promised it :) I am doing the cleanup
>
> Artemis:
> Deleting       1.5.6
> Deleting       2.6.1
> Deleting       2.6.2
> Deleting       2.6.3
> Deleting       2.6.4
> (2.7.0 will go after I send the announcement.. working on it.. I had a
> few issues on updating the website)
>
>
> Apollo:
> Removed
>
> NMS:
> Is it ok to remove 1.5.0? (I'm not sure if these two are active branches)
>
>
> for ActiveMQ:
>
> should I remove 5.14.5? I'm not sure if 5.14 is an active branch or not.
>
> On Fri, May 10, 2019 at 1:55 PM Robbie Gemmell <robbie.gemmell@gmail.com> wrote:
> >
> > Great, thanks Clebert.
> >
> > Robbie
> >
> > On Fri, 10 May 2019 at 01:10, Clebert Suconic <clebert.suconic@gmail.com>
wrote:
> > >
> > > Ok.  Thanks a lot to contribute to the discussion. That’s sensible.
> > >
> > > I will remove some older versions.
> > >
> > > On Thu, May 9, 2019 at 6:43 AM Robbie Gemmell <robbie.gemmell@gmail.com>
> > > wrote:
> > >
> > > > I noticed there are various older releases in the dist area being
> > > > mirrored that either definitely or probably should not be any longer.
> > > > Could PMC members clean them up as appropriate please?
> > > >
> > > > Apollo 1.7.1 is still being mirrored, it seems like it should not be
> > > > since its deprecated and isnt listed on the new site at all that I
> > > > see.
> > > >
> > > > For Artemis, 1.5.6, 2.6.1, 2.6.2, 2.6.3, and 2.6.4 are still being
> > > > mirrored and shouldn't be, they aren't mentioned on the main download
> > > > page for Artemis (2.7.0 is, presumably to become 2.8.0 later today),
> > > > and the past releases page links to the archive as would be expected
> > > > and not the mirrors. (2.7.0 should also be removed from mirroring
> > > > later after the download pages are updated for 2.8.0, which is now
> > > > mostly mirrored.)
> > > >
> > > > For the 5.x releases, 5.14.5 is still being mirrored but perhaps
> > > > should not be. The main download page for 5.x only mentions the latest
> > > > 5.15.9 release. The release page for 5.14.5 does still link to the
> > > > mirrors but you have to drill down to find that page, its over 2 years
> > > > old now and there doesn't seem to be intent to do further 5.14.x, so
> > > > its perhaps time to stop mirroring this release?
> > > >
> > > > Robbie
> > > >
> > > --
> > > Clebert Suconic
>
>
>
> --
> Clebert Suconic

Mime
View raw message