activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Shannon <christopher.l.shan...@gmail.com>
Subject Re: [PROPOSAL] ActiveMQ 5.15.10 release
Date Tue, 14 May 2019 10:32:43 GMT
I assume you mean 5.16.0

I've probably mentioned this a few times in various posts and chat but my
opinion is we need to support JDK 11 so I consider this issue a blocker
until resolved. https://issues.apache.org/jira/browse/AMQ-7087

5.16.0 should still be compatible to run on JDK 8 or JDK 11 but (since JDK
11 is the new LTS build) we should be able to run a build and pass all
tests using both 8 and 11 as well.  I have done work here to get it to
build with JDK 11 but all of the OSGi tests and stuff are broken and I'm
not sure how to fix it as I haven't worked very much with OSGi.

Here is the commit I started work on 6 months ago:
https://github.com/cshannon/activemq/commit/68c91621a0568a0d47e66a800833e1770c27b7d8

On Tue, May 14, 2019 at 1:53 AM Jean-Baptiste Onofré <jb@nanthrax.net>
wrote:

> Hi team,
>
> I started to review some PRs and I'm also working on some
> improvements/fixes PR (for OSGi, but also preparing better cloud support
> features).
>
> I would like to submit to vote ActiveMQ 5.15.10 over the week end or
> beginning of next week.
>
> No objection ?
>
> Thanks,
> Regards
> JB
> --
> Jean-Baptiste Onofré
> jbonofre@apache.org
> http://blog.nanthrax.net
> Talend - http://www.talend.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message