activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ravirake <ravirake1...@gmail.com>
Subject Hawtio service destroyed on slave after master server restart
Date Fri, 26 Jan 2018 17:36:40 GMT
Hi,

We have master and slave failover configuration. So when master goes down
the slave pick up but In a particular case when master is back online after
the failure, the slave hands over and in this case hawtio service is being
destroyed as seen in the logs below. Therefore the hawtio console doesn't
show up.

Is this a known issue? If not when can we expect the fix?

FYI: This issue is in *ActiveMQ Artemis 2.4.0*

11:46:16,478 INFO  [io.hawt.web.AuthenticationFilter] Destroying hawtio
authentication filter
11:46:16,479 INFO  [io.hawt.HawtioContextListener] *Destroying hawtio
services*
11:46:16,853 INFO  [org.apache.activemq.hawtio.plugin.PluginContextListener]
Destroyed artemis-plugin plugin
11:46:16,864 INFO 
[org.apache.activemq.hawtio.branding.PluginContextListener] Destroyed
activemq-branding plugin
11:46:16,877 INFO  [org.apache.activemq.artemis.core.server] AMQ221002:
Apache ActiveMQ Artemis Message Broker version 2.4.0
[67ff7eb6-e67c-11e7-ae7e-9801a79ac3c9] stopped, uptime 1 minute
11:46:16,877 INFO  [org.apache.activemq.artemis.core.server] AMQ221039:
Restarting as Replicating backup server after live restart
11:46:16,878 INFO  [org.apache.activemq.artemis.core.server] AMQ221000:
backup Message Broker is starting with configuration Broker Configuration
(clustered=true,journalDirectory=./data/journal,bindingsDirectory=./data/bindings,largeMessagesDirectory=./data/large-messages,pagingDirectory=./data/paging)

Thanks,
Ravi 



--
Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-Dev-f2368404.html

Mime
View raw message