activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clebert Suconic <clebert.suco...@gmail.com>
Subject Re: [DISCUSS/HELP] Help with ArtemisFeatureTest
Date Tue, 02 May 2017 17:22:47 GMT
thanks a lot...


this test is so weird.. I just cleared a box's repository and it fails
eventually.. but I think it's part of the test.. PaxExam seems
fragile...

At least now I know it's an issue with the test (probably).. I will go
ahead with releasing..


thanks a lot.

On Mon, May 1, 2017 at 11:29 PM, Michael André Pearce
<michael.andre.pearce@me.com> wrote:
> Just raised a PR.
>
> This particular test is running ok on local machine now. Let me know if it doesn't resolve
for you.
>
> I did have to clean build a couple times seems I had some previous 2.1 snapshot cached
locally that I needed to wipeout.
>
>
> Sent from my iPhone
>
>> On 1 May 2017, at 22:19, Clebert Suconic <clebert.suconic@gmail.com> wrote:
>>
>> I was going to release today, but ArtemisFeatureTest is failing *... I
>> don't want to release with that failure (Karaf integration wouldn't
>> work).
>>
>> *=https://github.com/apache/activemq-artemis/blob/master/tests/integration-tests/src/test/java/org/apache/activemq/artemis/tests/integration/karaf/ArtemisFeatureTest.java
>>
>>
>>
>> The Current failure is because of the missing epoll package from netty.
>>
>> org.osgi.service.resolver.ResolutionException: Unable to resolve root:
>> missing requirement [root] osgi.identity; osgi.identity=artemis;
>> type=karaf.feature; version="[2.1.0.SNAPSHOT,2.1.0.SNAPSHOT]";
>> filter:="(&(osgi.identity=artemis)(type=karaf.feature)(version>=2.1.0.SNAPSHOT)(version<=2.1.0.SNAPSHOT))"
>> [caused by: Unable to resolve artemis/2.1.0.SNAPSHOT: missing
>> requirement [artemis/2.1.0.SNAPSHOT] osgi.identity;
>> osgi.identity=artemis-amqp; type=karaf.feature [caused by: Unable to
>> resolve artemis-amqp/2.1.0.SNAPSHOT: missing requirement
>> [artemis-amqp/2.1.0.SNAPSHOT] osgi.identity;
>> osgi.identity=org.apache.activemq.artemis-amqp-protocol;
>> type=osgi.bundle; version="[2.1.0.SNAPSHOT,2.1.0.SNAPSHOT]";
>> resolution:=mandatory [caused by: Unable to resolve
>> org.apache.activemq.artemis-amqp-protocol/2.1.0.SNAPSHOT: missing
>> requirement [org.apache.activemq.artemis-amqp-protocol/2.1.0.SNAPSHOT]
>> osgi.wiring.package;
>> filter:="(osgi.wiring.package=org.apache.activemq.artemis.api.core)"
>> [caused by: Unable to resolve
>> org.apache.activemq.artemis-server-osgi/2.1.0.SNAPSHOT: missing
>> requirement [org.apache.activemq.artemis-server-osgi/2.1.0.SNAPSHOT]
>> osgi.wiring.package;
>> filter:="(osgi.wiring.package=io.netty.channel.epoll)"]]]]
>>
>>
>>
>>
>> So, if I edited features.xml and add this:
>>
>> <bundle>mvn:io.netty/netty-transport-native-epoll/${netty.version}</bundle>
>>
>>
>>
>> I will get a different error... and I can't get past that...
>>
>>
>>
>> Anyone have any ideas... please?????
>>
>>
>>
>> org.osgi.service.resolver.ResolutionException: Uses constraint
>> violation. Unable to resolve resource
>> org.apache.activemq.artemis-server-osgi
>> [org.apache.activemq.artemis-server-osgi/2.1.0.SNAPSHOT] because it is
>> exposed to package 'io.netty.buffer' from resources
>> org.apache.activemq.artemis-server-osgi
>> [org.apache.activemq.artemis-server-osgi/2.1.0.SNAPSHOT] and
>> io.netty.buffer [io.netty.buffer/4.1.10.Final] via two dependency
>> chains.
>>
>>
>> Chain 1:
>>
>>  org.apache.activemq.artemis-server-osgi
>> [org.apache.activemq.artemis-server-osgi/2.1.0.SNAPSHOT]
>>
>>    import: (&(osgi.wiring.package=io.netty.buffer)(version>=2.1.0)(!(version>=3.0.0)))
>>
>>     |
>>
>>    export: osgi.wiring.package: io.netty.buffer
>>
>>  org.apache.activemq.artemis-server-osgi
>> [org.apache.activemq.artemis-server-osgi/2.1.0.SNAPSHOT]
>>
>>
>> Chain 2:
>>
>>  org.apache.activemq.artemis-server-osgi
>> [org.apache.activemq.artemis-server-osgi/2.1.0.SNAPSHOT]
>>
>>    import: (osgi.wiring.package=io.netty.bootstrap)
>>
>>     |
>>
>>    export: osgi.wiring.package=io.netty.bootstrap; uses:=io.netty.buffer
>>
>>  io.netty.transport [io.netty.transport/4.1.10.Final]
>>
>>    import: (&(osgi.wiring.package=io.netty.buffer)(version>=4.1.0)(!(version>=5.0.0)))
>>
>>
>>
>> --
>> Clebert Suconic



-- 
Clebert Suconic

Mime
View raw message