activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ranail1 <robert.n...@nice.com>
Subject TempUsage disk / storage not being created for filecursor
Date Mon, 13 Feb 2017 15:02:57 GMT
I have a situation where the temporary storage is not being created when
memory reaches 70%. It will work if I use persistence=true but if I use
persistence=false then the tempStorage filecursor is not created. I look in
the activemq dir location and nothing. Given my configuration below is there
a setting I am missing that would allow for the creation of the temp
storage. 

I have set memory low in order to try to produce the content. As noted if I
use persistence=true it creates the Kahadb and temp dir content and it
writes messages to temp storage. If I set persistence=false then it does not
work. 

<amq:broker id="myBroker" useJmx="true" persistent="false"
brokerName="my-rta"
		start="true" deleteAllMessagesOnStartup="true" useShutdownHook="false">

		<amq:destinationPolicy>
			<amq:policyMap>
				<amq:policyEntries>
					<amq:policyEntry topic="myChannel">
						<amq:pendingSubscriberPolicy>
							<amq:fileCursor />
						</amq:pendingSubscriberPolicy>
					</amq:policyEntry>
					<amq:policyEntry topic="myAcd">
						<amq:pendingSubscriberPolicy>
							<amq:fileCursor />
						</amq:pendingSubscriberPolicy>
					</amq:policyEntry>
				</amq:policyEntries>
			</amq:policyMap>
		</amq:destinationPolicy>

		<amq:managementContext>
			<amq:managementContext useMBeanServer="true" createConnector="false"
createMBeanServer="false" />
		</amq:managementContext>

		<amq:systemUsage>
			<amq:systemUsage>
				<amq:memoryUsage>
					<amq:memoryUsage limit="50m" />
				</amq:memoryUsage>
				<amq:storeUsage>
					<amq:storeUsage limit="1g" />
				</amq:storeUsage>
				<amq:tempUsage>
					<amq:tempUsage limit="1g" />
				</amq:tempUsage>
			</amq:systemUsage>
		</amq:systemUsage>



--
View this message in context: http://activemq.2283324.n4.nabble.com/TempUsage-disk-storage-not-being-created-for-filecursor-tp4721915.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.

Mime
View raw message