activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John D. Ament" <johndam...@apache.org>
Subject Re: [DISCUSS] Require Java 8 for 5.15 and Artemis
Date Wed, 19 Oct 2016 13:51:56 GMT
+1 sounds good.

On Oct 19, 2016 09:49, "Claus Ibsen" <claus.ibsen@gmail.com> wrote:

> +1 to upgrade to Java 8
>
> On Wed, Oct 19, 2016 at 2:44 PM, Christopher Shannon
> <christopher.l.shannon@gmail.com> wrote:
> > With the release of Camel 2.18 I thought now was a good time to propose
> > this.  I think for the ActiveMQ 5.15 release we should bump the required
> > Java version to Java 8 as this will allow us to use Camel 2.18 so we can
> > finally fix our OSGi module and drop the deprecated Spring DM entirely.
> > This release probably won't go out until sometime next year and by that
> > time JDK 9 should be either released or close to being released and JDK 7
> > will have had its last public update nearly 2 years ago.
> >
> > Also, I figure we might as well do the same thing for Artemis.
> >
> > Any objections or reasons to stick with Java 7?
>
>
>
> --
> Claus Ibsen
> -----------------
> http://davsclaus.com @davsclaus
> Camel in Action 2: https://www.manning.com/ibsen2
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message