activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John D. Ament" <johndam...@apache.org>
Subject Re: [DISCUSS] Require Java 8 for 5.15 and Artemis
Date Thu, 20 Oct 2016 02:19:45 GMT
Just a late night thought.  What about bumping the major versions for both
to indicate the incompatibility?  It gives volunteers the option to back
port features if needed to the current release lines.

On Oct 19, 2016 17:10, "John D. Ament" <johndament@apache.org> wrote:

Well, I think the difference is that internally 5.x uses Camel for routing
in addition to the camel component.  Any camel integration for Artemis is
external.

John


On Wed, Oct 19, 2016 at 5:02 PM Clebert Suconic <clebert.suconic@gmail.com>
wrote:

> For artemis: I have used JDK 1.8 last release I built. I believe
> Martyn also used 1.8 on the releases he deployed.
>
> All the apache CIs for Artemis are using JDK 1.8 afaik. (will double
> check later)
>
> I have some internal CIs on my dev env that are also using 1.8.
>
> The only thing we didn't do is the require JVM on compilation. Would
> there be any issues on Camel?
>
> On Wed, Oct 19, 2016 at 2:55 PM, Christopher Shannon
> <christopher.l.shannon@gmail.com> wrote:
> > Well we do need 1.8 so we can use Camel 2.18 and fix OSGi stuff in 5.15.
> > And I figured it would be a bit odd if 5.x upgraded but Artemis didn't
> > upgrade.
> >
> >
> > On Wed, Oct 19, 2016 at 1:28 PM, Clebert Suconic <
> clebert.suconic@gmail.com>
> > wrote:
> >
> >> man... I'm messed up today.. wrong thread ... (on my previous message)
> >>
> >> anyways... If we can keep 1.7 for now and move it when we need it?
> >>
> >> I'm already using JDK 1.8 for dev, and I believe everybody is... all
> >> the CIs are on JDK 1.8, but from time to time I check on 1.7 just to
> >> be sure.
> >>
> >>
> >> My main concern is with clients.. from time to time I see users
> >> needing JDK 1.OOOOLD on clients.
> >>
> >>
> >>
> >> On Wed, Oct 19, 2016 at 1:26 PM, Clebert Suconic
> >> <clebert.suconic@gmail.com> wrote:
> >> > Actually, this was originally written by @CSchneider :)  ...
> >> >
> >> > On Wed, Oct 19, 2016 at 8:44 AM, Christopher Shannon
> >> > <christopher.l.shannon@gmail.com> wrote:
> >> >> With the release of Camel 2.18 I thought now was a good time to
> propose
> >> >> this.  I think for the ActiveMQ 5.15 release we should bump the
> required
> >> >> Java version to Java 8 as this will allow us to use Camel 2.18 so we
> can
> >> >> finally fix our OSGi module and drop the deprecated Spring DM
> entirely.
> >> >> This release probably won't go out until sometime next year and by
> that
> >> >> time JDK 9 should be either released or close to being released and
> JDK
> >> 7
> >> >> will have had its last public update nearly 2 years ago.
> >> >>
> >> >> Also, I figure we might as well do the same thing for Artemis.
> >> >>
> >> >> Any objections or reasons to stick with Java 7?
> >> >
> >> >
> >> >
> >> > --
> >> > Clebert Suconic
> >>
> >>
> >>
> >> --
> >> Clebert Suconic
> >>
>
>
>
> --
> Clebert Suconic
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message