activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ActiveMQ Investigation <ajay.ku...@winterflood.com>
Subject Openwire: New line character in message
Date Wed, 19 Oct 2016 13:47:40 GMT
Hello,

I am using openwire. When I receive FIX message, I am getting new line
character in beginning and end of the message from ActiveMQ broker.

Is there anyway to avoid these chr(10):

Message received:

Whole message [
35=AS|755=yaj0000314|70=yaj0000314|71=2|795=yaj0000314|794=8|87=3|857=1|54=2|55=MKS|48=GB0031274896|207=XLON|22=4|53=51|6=4.3359|15=GBP|453=1|448=WINS|447=D|452=1|75=20160219|60=20160219-11:44:55|63=0|64=20160223|78=1|79=507ZBIM|80=51|153=4.3359|154=221.13|120=GBP
]

Way it should be:
Whole message
[35=AS|755=yaj0000314|70=yaj0000314|71=2|795=yaj0000314|794=8|87=3|857=1|54=2|55=MKS|48=GB0031274896|207=XLON|22=4|53=51|6=4.3359|15=GBP|453=1|448=WINS|447=D|452=1|75=20160219|60=20160219-11:44:55|63=0|64=20160223|78=1|79=507ZBIM|80=51|153=4.3359|154=221.13|120=GBP]

Problem is that GBP gets a new line. Instead of removing them for every
message, is there any config on ActiveMQ side to say that don't receive new
line. OR I am missing some bit here.

We don't have two messages coming togather to delimit by new line so it's a
bit of trouble to remove these new line everytime.

Your help will be appreciated.



Thanks
AJ



--
View this message in context: http://activemq.2283324.n4.nabble.com/Openwire-New-line-character-in-message-tp4718083.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.

Mime
View raw message