activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John D. Ament" <johndam...@apache.org>
Subject Minimum maven version to compile artemis?
Date Mon, 21 Dec 2015 23:21:44 GMT
All,

I'd like to ask a broad question.  What should the minimum maven version be
to compile artemis?

In order to fix https://issues.apache.org/jira/browse/ARTEMIS-326 I cleaned
up a bunch of defined variables.  These variables were being duplicated in
every pom for checkstyle configuration it would seem.  Maven, as of 3.0.x
would recompute variable values each time requested, instead of caching the
value.

This behavior appears to be changed in 3.1+, where the value is computed
once at the root, and not over and over again.

So I'd like to ask, is it possible to make 3.1 the minimum maven version to
compile artemis?

Maven 3.0 is over 5 years old.  Maven 3.1 is 2.5 years old.

WDYT?

John

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message