activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Krzysztof Sobkowiak <krzys.sobkow...@gmail.com>
Subject ActiveMQ 5.13.x & Karaf 3.0.x
Date Fri, 04 Dec 2015 21:55:37 GMT
Hi

I tried to install 5.13.0 on Karaf 3.0.5 with following result:

karaf@root()> feature:install activemq-broker
Error executing command: Can't install feature activemq-broker/0.0.0:    
Could not start bundle mvn:org.apache.activemq/activemq-karaf/5.13.0 in feature(s) activemq-5.13.0:
Unresolved constraint in bundle activemq-karaf [105]: Unable to resolve 105.0: missing requirement
[105.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.8.0)(!(version>=2.0.0)))

Does it mean, ActiveMQ 5.13.x will be no more installable on Karaf 3, which exports org.osgi.framework
in version 1.7.0?

Regards
Krzysztof


-- 
Krzysztof Sobkowiak

JEE & OSS Architect, Integration Architect
Apache Software Foundation Member (http://apache.org/)
Apache ServiceMix Committer & PMC Member (http://servicemix.apache.org/)
Senior Solution Architect @ Capgemini SSC (http://www.capgeminisoftware.pl/)

Mime
View raw message