activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Renato MarroquĂ­n Mogrovejo <renatoj.marroq...@gmail.com>
Subject Maven dependencies
Date Sun, 09 Aug 2015 08:08:53 GMT
Hi all,

I am working towards an integration of ActiveMQ and Samza [1].
I have been playing around with ActiveMQ following this tutorial here [2]
which is very similar to the actual ActiveMQ webpage. Everything was great
and fun. Then, I tried upgrading the dependencies in order to use the
latest available versions but I think I need some help on it.

* org.springframework.spring --> Tutorial: 2.5.5 --> Latest: ???
* org.apache.camel.camel-activemq --> Tutorial: 1.1.0 --> Latest: ???

I tried replacing it with org.apache.activemq.activemq-camel 5.11.1 but I
got
[ERROR] Failed to execute goal
org.apache.activemq.tooling:maven-activemq-plugin:5.2.0:run (default-cli)
on project mq: Failed to start ActiveMQ Broker: Error creating bean with
name 'org.apache.activemq.xbean.XBeanBrokerService#0' defined in URL
[file:./conf/activemq.xml]: Invocation of init method failed; nested
exception is java.lang.RuntimeException: Fatally failed to create
SystemUsageorg.apache.activemq.store.kahadb.KahaDBPersistenceAdapte

* org.apache.activemq.tooling.maven-activemq-plugin --> Tutorial: 5.2.0 -->
Latest: 5.7.0
But I couldn't figure out the correct versions for spring and camel-activemq

* org.apache.activemq.activemq-core --> Tutorial: 5.2.0 --> Latest: 5.7.0
is this the latest and correct version??

* And replace JBoss javax.jms depency for
org.apache.geronimo.specs.geronimo-jms_1.1_spec (1.1.1)
is this fine? or should I supposed that I just got lucky on this one?

If anybody could help me sorting out the correct versions or point me to a
more updated documentation would be great! Thanks!


Renato M.

[1] https://issues.apache.org/jira/browse/SAMZA-587
[2]
http://pookey.co.uk/wordpress/archives/74-playing-with-activemq-using-maven

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message