activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Shannon <christopher.l.shan...@gmail.com>
Subject Re: Maven dependencies
Date Mon, 10 Aug 2015 16:16:50 GMT
The easiest way to figure out dependencies is probably to just look at the
parent pom that ActiveMQ is using.  Here it is on github for 5.11.1
https://github.com/apache/activemq/blob/863e8a5d1ba38f262bdbec4484d704fba8e4f695/pom.xml

Your specific issue is that you have mismatched versions of ActiveMQ
modules and all of your versions for ActiveMQ should match up.  So if you
update activemq-camel to 5.11.1 then activemq-maven-plugin should be the
same, etc. (It looks like you are using 5.2.0 for the maven plugin instead
of 5.11.1)  The spring version should be at least 3.2.x but you should be
able to use a newer version and have it work.

On Sun, Aug 9, 2015 at 4:08 AM, Renato MarroquĂ­n Mogrovejo <
renatoj.marroquin@gmail.com> wrote:

> Hi all,
>
> I am working towards an integration of ActiveMQ and Samza [1].
> I have been playing around with ActiveMQ following this tutorial here [2]
> which is very similar to the actual ActiveMQ webpage. Everything was great
> and fun. Then, I tried upgrading the dependencies in order to use the
> latest available versions but I think I need some help on it.
>
> * org.springframework.spring --> Tutorial: 2.5.5 --> Latest: ???
> * org.apache.camel.camel-activemq --> Tutorial: 1.1.0 --> Latest: ???
>
> I tried replacing it with org.apache.activemq.activemq-camel 5.11.1 but I
> got
> [ERROR] Failed to execute goal
> org.apache.activemq.tooling:maven-activemq-plugin:5.2.0:run (default-cli)
> on project mq: Failed to start ActiveMQ Broker: Error creating bean with
> name 'org.apache.activemq.xbean.XBeanBrokerService#0' defined in URL
> [file:./conf/activemq.xml]: Invocation of init method failed; nested
> exception is java.lang.RuntimeException: Fatally failed to create
> SystemUsageorg.apache.activemq.store.kahadb.KahaDBPersistenceAdapte
>
> * org.apache.activemq.tooling.maven-activemq-plugin --> Tutorial: 5.2.0 -->
> Latest: 5.7.0
> But I couldn't figure out the correct versions for spring and
> camel-activemq
>
> * org.apache.activemq.activemq-core --> Tutorial: 5.2.0 --> Latest: 5.7.0
> is this the latest and correct version??
>
> * And replace JBoss javax.jms depency for
> org.apache.geronimo.specs.geronimo-jms_1.1_spec (1.1.1)
> is this fine? or should I supposed that I just got lucky on this one?
>
> If anybody could help me sorting out the correct versions or point me to a
> more updated documentation would be great! Thanks!
>
>
> Renato M.
>
> [1] https://issues.apache.org/jira/browse/SAMZA-587
> [2]
> http://pookey.co.uk/wordpress/archives/74-playing-with-activemq-using-maven
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message