activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Krzysztof Sobkowiak <krzys.sobkow...@gmail.com>
Subject commons-pool2 upgrade in 5.12.x
Date Thu, 27 Aug 2015 18:42:44 GMT
Hi

The upgrade to Commons Pool 2.3.0 (AMQ-5721) made some problems in OSGi environment. Its's
described in this thread http://activemq.2283324.n4.nabble.com/OSGi-ClassNotFoundException-when-trying-to-upgrade-from-5-11-1-to-5-12-0-td4701124.html
and issues AMQ-5861 and AMQ-5944. It currently also blocks us to use the new
version in ServiceMix. I have provided a pull request in AMQ-5861 which upgrades Common Pool
to version 2.4.2. Could you please check it and include (if it's ok) it in 5.12.1 (and master)?

Regards
Krzysztof



-- 
Krzysztof Sobkowiak (@ksobkowiak)

JEE & OSS Architect, Integration Architect
Apache Software Foundation <http://apache.org/> Member
Apache ServiceMix <http://servicemix.apache.org/> Committer & PMC Member
Senior Solution Architect @ Capgemini SSC <http://www.capgeminisoftware.pl/>

Mime
View raw message