activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clebert Suconic <clebert.suco...@gmail.com>
Subject Re: Artemis and Eclipse...
Date Mon, 08 Jun 2015 21:23:52 GMT
The only thing I remember we had to add JDK 1.8 to the equation was
some option we needed for building javadocs. Perhaps there is a better
way to solve that.

Right now the codebase is not using anything specific to JDK 1.8.  (I
mean.. at least that's the idea. we could have slipped something.. but
I don't recall anything specific to java8 in the codebase)

On Mon, Jun 8, 2015 at 2:35 PM, Daniel Kulp <dkulp@apache.org> wrote:
> I’ve updated a bunch of things so that Artemis now loads fairly easily into Eclipse
without any errors for all the non-example things.    I haven’t attempted the examples yet.
>
> Just have a couple of questions:
>
> 1) In the poms, we specify that Java8 is required to build, but java7 is used for the
source/target.   Thus, Eclipse will pick up the Java7 runtime.  It seems to work OK so I’m
kind of wondering why we require Java8 to build.  Maybe in the examples someplace?
>
> 2) artemis-dto has a profile for jdk-1.5.   I assume that is not needed at all as there
is no way it would ever be triggered.   I think the ibmjdk profile in there is irrelevant
as well? (seems to reference things about differences between 1.5 and 1.6)
>
>
>
>
> --
> Daniel Kulp
> dkulp@apache.org - http://dankulp.com/blog
> Talend Community Coder - http://coders.talend.com
>



-- 
Clebert Suconic
http://community.jboss.org/people/clebert.suconic@jboss.com
http://clebertsuconic.blogspot.com

Mime
View raw message