activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Conway (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (ACTIVEMQ6-88) Proton 0.9 RC 2 blocker - proton_tests.utils.SyncRequestResponseTest.test_request_response ........ fail
Date Mon, 16 Mar 2015 13:48:38 GMT

     [ https://issues.apache.org/jira/browse/ACTIVEMQ6-88?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alan Conway closed ACTIVEMQ6-88.
--------------------------------
    Resolution: Invalid

> Proton 0.9 RC 2 blocker - proton_tests.utils.SyncRequestResponseTest.test_request_response
........ fail
> --------------------------------------------------------------------------------------------------------
>
>                 Key: ACTIVEMQ6-88
>                 URL: https://issues.apache.org/jira/browse/ACTIVEMQ6-88
>             Project: Apache ActiveMQ 6
>          Issue Type: Bug
>            Reporter: Alan Conway
>
> From:	Ken Giusti <kgiusti@redhat.com>
> Reply-to:	proton@qpid.apache.org
> To:	users@qpid.apache.org
> Cc:	proton@qpid.apache.org
> Subject:	Re: [VOTE] Proton 0.9 RC 2
> Date:	Mon, 16 Mar 2015 09:00:36 -0400 (EDT)
> Hate to be a party-pooper, but:
> 1: proton_tests.utils.SyncRequestResponseTest.test_request_response ........ fail
> 1: Error during test:  Traceback (most recent call last):
> 1:     File "/home/kgiusti/Downloads/qpid-proton-0.9-rc-2/tests/python/proton-test",
line 355, in run
> 1:       phase()
> 1:     File "/home/kgiusti/Downloads/qpid-proton-0.9-rc-2/tests/python/proton_tests/utils.py",
line 89, in test_request_response
> 1:       connection = BlockingConnection(server.url, timeout=self.timeout)
> 1:     File "/home/kgiusti/Downloads/qpid-proton-0.9-rc-2/proton-c/bindings/python/proton/utils.py",
line 198, in __init__
> 1:       self.conn = self.container.connect(url=self.url, handler=self, ssl_domain=ssl_domain,
reconnect=False)
> 1:     File "/home/kgiusti/Downloads/qpid-proton-0.9-rc-2/proton-c/bindings/python/proton/reactor.py",
line 616, in connect
> 1:       connector.ssl_domain = ssl_domain or self.ssl.client
> 1:   AttributeError: 'NoneType' object has no attribute 'client'
> 1: Totals: 323 tests, 290 passed, 32 skipped, 0 ignored, 1 failed
> 1/1 Test #1: python-test ......................***Failed  Required regular expression
not found.Regex=[Totals: .* 0 failed
> When the openssl devel libraries are not installed.   Seems like a legit bug: reactor
is assuming a non-None SSL domain is stored in self.ssl.client in that particular codepath.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message