activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jessy (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-5660) Dequeue count for Topics does not increase for durable subscribers
Date Thu, 12 Mar 2015 22:11:38 GMT

     [ https://issues.apache.org/jira/browse/AMQ-5660?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jessy updated AMQ-5660:
-----------------------
    Description: 
I upgraded my ActiveMQ from 5.2.1 to 5.6.0.
I have durable topic subscribers .
I see the "subcribers" tab in activemqConsole and i find that the these subscribers are able
to consume the messages from the topic . 
The "subcribers" tab shows up all the counter's correctly - the dispatched counter equals
enqueue counter and dequeue counters.

However, When i check the topic's enque and dequeue count in "Topics" tab, I see the dequeue
count is always zero and not increased ,even thought the subcribers are reported to consume
them as seen in the "subcribers" tab.

I did not face this issue with my previous version of ActiveMQ - version 5.2.1. 
Version ActiveMQ 5.2.1 works very good in showing up the correct dequeue count for durable
topic subscribers.

My subscribers are on different versions of ActiveMQ.

Please advise the steps that i need to consider get the dequeue counter match with the enqueue
counter .

I came accross exactly the same issue on Jira for version 5.8.0.  -- https://issues.apache.org/jira/browse/AMQ-5660
If this is a bug to be fixed, please help us get a fix for this.

Thanks 
Jessy

  was:
I upgraded my ActiveMQ from 5.2.1 to 5.6.0.
I have durable topic subscribers .
I see the "subcribers" tab in activemqConsole and i find that the these subscribers are able
to consume the messages from the topic . 
The "subcribers" tab shows up all the counter's correctly - the dispatched counter equals
enqueue counter and dequeue counters.

However, When i check the topic's enque and dequeue count in "Topics" tab, I see the dequeue
count is always zero and not increased ,even thought the subcribers are reported to consume
them as seen in the "subcribers" tab.

I did not face this issue with my previous version of ActiveMQ - version 5.2.1. 
Version ActiveMQ 5.2.1 works very good in showing up the correct dequeue count for durable
topic subscribers.

My subscribers are on different versions of ActiveMQ.

Please advise the steps that i need to consider get the dequeue counter match with the enqueue
counter .
If this is a bug to be fixed, please help us get a fix for this.

Thanks 
Jessy


> Dequeue count for Topics does not increase for durable subscribers
> ------------------------------------------------------------------
>
>                 Key: AMQ-5660
>                 URL: https://issues.apache.org/jira/browse/AMQ-5660
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.6.0
>         Environment: 
>            Reporter: Jessy
>
> I upgraded my ActiveMQ from 5.2.1 to 5.6.0.
> I have durable topic subscribers .
> I see the "subcribers" tab in activemqConsole and i find that the these subscribers are
able to consume the messages from the topic . 
> The "subcribers" tab shows up all the counter's correctly - the dispatched counter equals
enqueue counter and dequeue counters.
> However, When i check the topic's enque and dequeue count in "Topics" tab, I see the
dequeue count is always zero and not increased ,even thought the subcribers are reported to
consume them as seen in the "subcribers" tab.
> I did not face this issue with my previous version of ActiveMQ - version 5.2.1. 
> Version ActiveMQ 5.2.1 works very good in showing up the correct dequeue count for durable
topic subscribers.
> My subscribers are on different versions of ActiveMQ.
> Please advise the steps that i need to consider get the dequeue counter match with the
enqueue counter .
> I came accross exactly the same issue on Jira for version 5.8.0.  -- https://issues.apache.org/jira/browse/AMQ-5660
> If this is a bug to be fixed, please help us get a fix for this.
> Thanks 
> Jessy



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message