activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clebert Suconic <clebert.suco...@gmail.com>
Subject Re: ActiveMQ 6.0.0 required Java 8?
Date Thu, 19 Mar 2015 02:02:17 GMT
At this point we need java8 to build the source, but the target
compilation still java 1.7

We are not using any java8 features at this point. We kind of stepped
back on being strict about java8. We could have updated the docs but
since we kept java8 to build the source we are still recommending
java8.


The testsuite is running on java8 now, but it has been on java7 up
till recently.


I would recommend java8 as java7 is almost EOL but it still safe to
use java7 on the binaries at this point.


Are you evaluating it already? We are looking for feedback about it...
we are still under voting for the release.. so any feedback helps!




On Wed, Mar 18, 2015 at 9:48 PM, Kevin Burton <burton@spinn3r.com> wrote:
> Just curious.  We’re still on Java 1.7.  I assume Java 8 features are
> actually used.  Might be bad news for us but I can see it being a
> reasonable requirement at this point.
>
> --
>
> Founder/CEO Spinn3r.com
> Location: *San Francisco, CA*
> blog: http://burtonator.wordpress.com
> … or check out my Google+ profile
> <https://plus.google.com/102718274791889610666/posts>
> <http://spinn3r.com>



-- 
Clebert Suconic
http://community.jboss.org/people/clebert.suconic@jboss.com
http://clebertsuconic.blogspot.com

Mime
View raw message