activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robbie Gemmell (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMQ-5608) connecting with username and SimpleAuthenticationPlugin defined without any users leads to NPE
Date Mon, 23 Feb 2015 17:48:11 GMT

     [ https://issues.apache.org/jira/browse/AMQ-5608?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robbie Gemmell resolved AMQ-5608.
---------------------------------
    Resolution: Fixed

Change made to prevent the NPE in: https://git-wip-us.apache.org/repos/asf?p=activemq.git;a=commit;h=1406d40ac34fedb0be2e5bc5998844a46ff15760

> connecting with username and SimpleAuthenticationPlugin defined without any users leads
to NPE
> ----------------------------------------------------------------------------------------------
>
>                 Key: AMQ-5608
>                 URL: https://issues.apache.org/jira/browse/AMQ-5608
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.11.1
>            Reporter: Robbie Gemmell
>             Fix For: 5.12.0
>
>
> If a SimpleAuthenticationPlugin is defined in the configuration without any users element,
then when a client which does supply a username attempts to connect an NPE occurs in the broker.
> E.g, defining broker config as:
> {noformat}
> <simpleAuthenticationPlugin anonymousAccessAllowed="true" />
> {noformat}
> And trying to log in, results in:
> {noformat}
> java.lang.NullPointerException
>         at org.apache.activemq.security.SimpleAuthenticationBroker.addConnection(SimpleAuthenticationBroker.java:83)
> ...
> <snip>
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message