activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arthur Naseef (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-5574) OSGi import ranges for javax.jms should include version 2.0
Date Mon, 09 Feb 2015 23:04:36 GMT

    [ https://issues.apache.org/jira/browse/AMQ-5574?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14313100#comment-14313100
] 

Arthur Naseef commented on AMQ-5574:
------------------------------------

>From what I understand of the JMS 2 spec, I agree; allow JMS 2.0 clients.  I also agree
with jcarman - it makes sense to open this up to 2.x updates since they should remain backward
compatible.

> OSGi import ranges for javax.jms should include version 2.0
> -----------------------------------------------------------
>
>                 Key: AMQ-5574
>                 URL: https://issues.apache.org/jira/browse/AMQ-5574
>             Project: ActiveMQ
>          Issue Type: Improvement
>          Components: OSGi/Karaf
>    Affects Versions: 5.11.0
>            Reporter: Matt Pavlovich
>            Priority: Minor
>
> The import ranges for the ActiveMQ client bundles should allow, not exclude version 2.0
of the javax.jms API, since JMS 2.0 is backwards compatible with 1.1.  
> This allows for ActiveMQ client jars to be used in runtimes with other JMS 2.0 clients.
> Should be:
> javax.jms;version=[1.1,2] 
> instead of:
> javax.jms;version=[1.1,2)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message