activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-5538) Queues not delivering messages
Date Mon, 26 Jan 2015 15:36:35 GMT

    [ https://issues.apache.org/jira/browse/AMQ-5538?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14291961#comment-14291961
] 

Timothy Bish commented on AMQ-5538:
-----------------------------------

Would advise you try and create a unit test that demonstrates your use case and the problematic
behaviour. 

> Queues not delivering messages
> ------------------------------
>
>                 Key: AMQ-5538
>                 URL: https://issues.apache.org/jira/browse/AMQ-5538
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.9.0, 5.10.0
>            Reporter: Eric Robinson
>            Priority: Minor
>
> Queues can get into a state where they will not deliver messages to old or new  consumers.
> Condition that this can occur.
> Producer is sending persistent messages.
> Producer is configured with a failover with just one broker.
> Producer times out because of a network issue.
> Broker is configured with persistence disabled.
> There is a state when the producer will send a duplicate message to the queue and cause
the Queue to print a "Duplicate Message" message in the logs and after that the Queue will
stop providing messages to the consumers.
> A work around for this is to configure all producers to send their messages with persistence
turned off.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message