activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John D. Ament (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-5383) JMS 2.0 Client APIs Support
Date Fri, 02 Jan 2015 13:07:13 GMT

    [ https://issues.apache.org/jira/browse/AMQ-5383?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14262877#comment-14262877
] 

John D. Ament commented on AMQ-5383:
------------------------------------

I have raised the following PR:

https://github.com/apache/geronimo-specs/pull/2

[~romain.manni-bucau] if you could please review and generate appropriate patch.

> JMS 2.0 Client APIs Support
> ---------------------------
>
>                 Key: AMQ-5383
>                 URL: https://issues.apache.org/jira/browse/AMQ-5383
>             Project: ActiveMQ
>          Issue Type: New Feature
>          Components: JMS client
>            Reporter: John D. Ament
>
> I'd like to propose improving upon ActiveMQ by adding client API support to the JMS client.
 One way to do this would be to throw out the current client JAR and replace it with a new
one based on JMS 2.  That wouldn't be a good idea, many people are happy to use JMS 1.1 and
I feel we should let them continue.
> Antoher way is to create a new JAR, activemq-jm2-client, which extends the existing 1.1
client JAR for 2.0 APIs.  This would allow the core activemq to remain on Java 6, and allow
just this API JAR to be on Java 7 (due to the AutoCloseable requirement).
> I've already started putting together a geronimo spec jar for JMS 2 support.  You can
see that here: https://github.com/johnament/geronimo-specs/tree/jms2/geronimo-jms_2.0_spec



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message