activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robbie Gemmell (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-5490) broker does not write out supported version header
Date Wed, 17 Dec 2014 13:05:14 GMT

    [ https://issues.apache.org/jira/browse/AMQ-5490?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14249815#comment-14249815
] 

Robbie Gemmell commented on AMQ-5490:
-------------------------------------

I notice you said affects 5.10. Have you tried with trunk? Tim made changes on AMQ-5475.

> broker does not write out supported version header
> --------------------------------------------------
>
>                 Key: AMQ-5490
>                 URL: https://issues.apache.org/jira/browse/AMQ-5490
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: AMQP
>    Affects Versions: 5.10.0
>            Reporter: Gordon Sim
>
> If a pre 1.0 client attempt to connect, the broker simply closes the socket on reading
the protocol-header sent by the client. This prevents the client from realising it is a mismatched
version (and possibly trying with 1.0)
> From the spec (2.2):
> {noformat}
>     If the requested protocol version is not supported, the server MUST
>     send a protocol header with a supported protocol version and then
>     close the socket.
> and
>     If the server cannot parse the protocol header, the server MUST send
>     a valid protocol header with a supported protocol version and then 
>     close the socket.
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message