activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nikolay Pakudin (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-5466) Lost persistent message sent to detached consumer before keepAliveInterval exceed
Date Mon, 01 Dec 2014 12:57:18 GMT

     [ https://issues.apache.org/jira/browse/AMQ-5466?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nikolay Pakudin updated AMQ-5466:
---------------------------------
    Priority: Critical  (was: Major)

> Lost persistent message sent to detached consumer before keepAliveInterval exceed
> ---------------------------------------------------------------------------------
>
>                 Key: AMQ-5466
>                 URL: https://issues.apache.org/jira/browse/AMQ-5466
>             Project: ActiveMQ
>          Issue Type: Bug
>         Environment: Maс OS X 10.9.5
> apache-activemq-5.10.0
> java version "1.6.0_65" Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)
>            Reporter: Nikolay Pakudin
>            Priority: Critical
>
> What I do
> - There is a MQTT client - Android application. It connects to server and creates topic.
> - Sent there message with all default settings and payload {"name":"1st message"} by
ActiveMQ console. Message is successfully delivered. If open Active Subscribers, enqueued
= 1, and dequeued = 1
> - Turn on Airplane mode at Android, so there is no connection really, but ActiveMQ still
shows it in Active Subscribers.
> - Send message WITH checkbox Persistent delivery and payload {"name":"persistent"} If
open Active Subscribers, enqueued = 2, and dequeued = 2
> - Send message WITHOUT checkbox Persistent delivery and payload {"name":"not persistent"}
If open Active Subscribers, enqueued = 3, and dequeued = 2
> - Turn off Airplane mode at Android, connection appears and only one message is delivered
- not persistent.
> What I tried
> - Restart ActiveMQ.
> - Send a few persistent and a few not persistent messages - not persistent are delivered,
persistent aren't
> - Delete ActiveMQ and extract again.
> - Rebuild Android application and clean all data at phone.
> Messages, sent after keepAliveInterval exceed are delivered successfully.
> I reproduced it at least 20 times.
> I found http://activemq.2283324.n4.nabble.com/Random-persistent-messages-lost-tt3826331.html
, but it seems, that I have the other problem.
> Configuration
> conf/activemq.xml - default, with change 1 line (twice added "+nio")
> <transportConnector name="mqtt+nio" uri="mqtt+nio://0.0.0.0:1883maximumConnections=1000&amp;wireFormat.maxFrameSize=104857600"/>



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message