activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tamilmaran (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-5432) Activemq Failover is not working when the remote computer is turned off
Date Wed, 12 Nov 2014 05:46:33 GMT

     [ https://issues.apache.org/jira/browse/AMQ-5432?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tamilmaran updated AMQ-5432:
----------------------------
    Description: 
we have used following failover URl:-
activemq:failover://(ssl://10.2.114.40:61617?transport.serverName=MCCActiveMQBroker,ssl://10.2.152.190:61617?transport.serverName=MCCActiveMQBroker,ssl://10.2.112.178:61617?transport.serverName=MCCActiveMQBroker)?transport.randomize=false&transport.startupMaxReconnectAttempts=0&transport.timeout=5000

If the computer 10.2.114.40 is turned off, then it throws error and connection not created
even if the computers 10.2.152.190 and 10.2.112.178 are running.

Testcase 1:
10.2.114.40 is ON but stopped ActiveMQ
10.2.152.190 is ON and started ActiveMQ there
This case is working for the failover.

Testcase 2:
10.2.114.40 is turned OFF
10.2.152.190 is ON and started ActiveMQ there
This case is not working for the failover.




  was:
we have used following failover URl:-
activemq:failover://(ssl://10.2.114.40:61617?transport.serverName=MCCActiveMQBroker,ssl://10.2.152.190:61617?transport.serverName=MCCActiveMQBroker,ssl://10.2.112.178:61617?transport.serverName=MCCActiveMQBroker)?transport.randomize=false&transport.startupMaxReconnectAttempts=0&transport.timeout=5000

If the computer 10.2.114.40 is turned off, then it throws error and connection not created
even if the computer 10.2.152.190,10.2.112.178 are running.

Testcase 1:
10.2.114.40 is ON but stopped ActiveMQ
10.2.152.190 is ON and started ActiveMQ there
This case is working for the failover.

Testcase 2:
10.2.114.40 is turned OFF
10.2.152.190 is ON and started ActiveMQ there
This case is not working for the failover.





> Activemq Failover is not working when the remote computer is turned off
> -----------------------------------------------------------------------
>
>                 Key: AMQ-5432
>                 URL: https://issues.apache.org/jira/browse/AMQ-5432
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.9.1
>         Environment: activeMQ,NMS
>            Reporter: Tamilmaran
>
> we have used following failover URl:-
> activemq:failover://(ssl://10.2.114.40:61617?transport.serverName=MCCActiveMQBroker,ssl://10.2.152.190:61617?transport.serverName=MCCActiveMQBroker,ssl://10.2.112.178:61617?transport.serverName=MCCActiveMQBroker)?transport.randomize=false&transport.startupMaxReconnectAttempts=0&transport.timeout=5000
> If the computer 10.2.114.40 is turned off, then it throws error and connection not created
even if the computers 10.2.152.190 and 10.2.112.178 are running.
> Testcase 1:
> 10.2.114.40 is ON but stopped ActiveMQ
> 10.2.152.190 is ON and started ActiveMQ there
> This case is working for the failover.
> Testcase 2:
> 10.2.114.40 is turned OFF
> 10.2.152.190 is ON and started ActiveMQ there
> This case is not working for the failover.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message