activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "clebert suconic (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (ACTIVEMQ6-4) Rename packages to ActiveMQ
Date Fri, 14 Nov 2014 02:35:33 GMT

    [ https://issues.apache.org/jira/browse/ACTIVEMQ6-4?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14211731#comment-14211731
] 

clebert suconic edited comment on ACTIVEMQ6-4 at 11/14/14 2:34 AM:
-------------------------------------------------------------------

I have to rename all the HornetQException classes in order to fix the native code... The code
has some exception being thrown from the native side in certain cases and I need to fix this
now

Instead of making them HornetQException I will call them all QException, QBuffer... etc...
 (the activemq is already part of the package naming.. so I don't think it really matters
to call them ActiveMQException).. unless anyone has a strong feeling about it.


Also, I think we should have called the package name activemq instead of activemq6... I don't
want to later move all the packages to activemq7... same goes with the directory naming on
the projects... activemq6-native, etc... .. (small issue really) but I wanted to get some
consensus on it before I moved anything else now.

On the directory names I'm actually thinking about renaming them to just native, dto, etc..
simpler! dropping the project name from every sub-project (it would just be on the parent..
simpler naming)


was (Author: clebertsuconic):
I have to rename all the HornetQException classes in order to fix the native code... The code
has some exception being thrown from the native side in certain cases and I need to fix this
now

Instead of making them HornetQException I will call them all QException, QBuffer... etc...
 (the activemq is already part of the package naming.. so I don't think it really matters
to call them ActiveMQException).. unless anyone has a strong feeling about it.


Also, I think we should have called the package name activemq instead of activemq6... I don't
want to later move all the packages to activemq7... same goes with the directory naming..
(small issue really) but I wanted to get some consensus on it before I moved anything else
now.

> Rename packages to ActiveMQ
> ---------------------------
>
>                 Key: ACTIVEMQ6-4
>                 URL: https://issues.apache.org/jira/browse/ACTIVEMQ6-4
>             Project: Apache ActiveMQ 6
>          Issue Type: Improvement
>            Reporter: Martyn Taylor
>            Assignee: Andy Taylor
>             Fix For: 6.0.0
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message