activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henrik Karlsson (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-5408) jaasDualAuthenticationPlugin with client authentication not working for networkConnector
Date Thu, 23 Oct 2014 18:41:34 GMT

     [ https://issues.apache.org/jira/browse/AMQ-5408?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Henrik Karlsson updated AMQ-5408:
---------------------------------
    Attachment: conf.zip

Adding the conf I'm using. Can't include the client keystore because it's a real certificate.
Tried to use keystores in the dist (client.ks, client.ts) but the certificate in client.ks
has expired so that doesn't work...

> jaasDualAuthenticationPlugin with client authentication not working for networkConnector
> ----------------------------------------------------------------------------------------
>
>                 Key: AMQ-5408
>                 URL: https://issues.apache.org/jira/browse/AMQ-5408
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Transport
>    Affects Versions: 5.10.0
>         Environment: Windows, Java 1.7
>            Reporter: Henrik Karlsson
>         Attachments: conf.zip
>
>
> When using jaasDualAuthentication with username/password for tcp connections and certification
authentication for ssl, this works just fine then connection as a client. But when I try to
setup a network connector over ssl with certification authentication it fails to connect with
this error:
> java.lang.SecurityException: User name [null] or password is invalid.
> I also tried with nio+ssl with the same result
> If I change to jaasCertificateAuthentication it works for ssl connections but the non
ssl fails (as expected)
> When I use nio+ssl with jaasCertificateAuthentication this also fails with this error:
> java.lang.SecurityException: Unable to authenticate transport without SSL certificate.
> But after failing 3 times it finally connects successfully on the 4:th attempt.
> So it seems that  jaasDualAuthentication doesn't work with Certificate Authentication.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message