activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cfaini <cfa...@gmail.com>
Subject Segmentation fault when using ActiveMQ-cpp w/ gcc-43.2
Date Mon, 29 Sep 2014 18:21:22 GMT
Hey there. I have been starting to work with ActiveMQ-cpp. Originally it
worked perfectly for me in my tests. However, I recently had to change my
environment and compiler from Solaris 10 w/ gcc-4.3.2 to Solaris 11 w/
gcc-4.5.2. I was able to get the ActiveMQ-cpp libraries to compile just
fine, but as soon as I run the example code from the ActiveMQ-cpp website it
generates a segmentation fault as soon as the threads try to join.
 
The code that I am trying to run is located here:
http://activemq.apache.org/cms/example.html. It ran just fine when I was
using an older version of GCC.
 
I get the following output from my code: 
======================================= 
Starting the example: 
---------------------------------------------------------------------- 
HelloWorldConsumer::run 
HelloWorldProducer::run 
Sent message #1 from thread -4196748 
Segmentation Fault (core dumped) 

When looking into this error, it seems like Decaf (a part of the
ActiveMQ-CPP lirbary) is trying to destroy a null pointer Mutex.

Are there any known issues/fixes for Active MQ with my version of GCC? I am
using what is currently the latest version of ActiveMQ-cpp: 3.8.3 

I am reposting this from the User forums because I'm thinking this is
probably the propper forums for this sort of issue.



--
View this message in context: http://activemq.2283324.n4.nabble.com/Segmentation-fault-when-using-ActiveMQ-cpp-w-gcc-43-2-tp4686000.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.

Mime
View raw message