activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (AMQ-5250) temp queue not working after long run of activemq
Date Tue, 12 Aug 2014 22:44:12 GMT

     [ https://issues.apache.org/jira/browse/AMQ-5250?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Timothy Bish closed AMQ-5250.
-----------------------------

    Resolution: Cannot Reproduce

No test case to investigate and from the description it sounds like normal temp queue behaviour
as the lifetime is linked to that of its connection so if the connection goes down the Queues
go away.  

> temp queue not working after long run of activemq
> -------------------------------------------------
>
>                 Key: AMQ-5250
>                 URL: https://issues.apache.org/jira/browse/AMQ-5250
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.9.0
>            Reporter: Rural Hunter
>             Fix For: WAITING_FOR_TEST
>
>
> We encounterred a problem when using temp queue for request/reply pattern. It worked
normally but after a long time lets say several weeks, the applications using temp queue started
to report errors:
> 2014-06-25 08:25:59 [WARNING] Message back to the server fails´╝ü
> javax.jms.InvalidDestinationException: Cannot publish to a deleted Destination: temp-queue://ID:myserver-45345-1403492084155-1:1:259
> at org.apache.activemq.ActiveMQSession.send(ActiveMQSession.java:1748)
> at org.apache.activemq.ActiveMQMessageProducer.send(ActiveMQMessageProducer.java:289)
> at org.apache.activemq.ActiveMQMessageProducer.send(ActiveMQMessageProducer.java:224)
> at org.apache.activemq.ActiveMQMessageProducerSupport.send(ActiveMQMessageProducerSupport.java:300)
> I created a test application to test the temp when the problem happened and found this:
On each connection, the temp queue worked once and the second time it failed. I also tried
to monitor messages in ActiveMQ.Advisory.TempQueue. But I could only receive one message after
I subsribed on it everytime. 
> I checked the activemq log and there was nothing about the problem. Other applications
not using temp queue worked fine. This happened twice in recent month. I just had to restart
activemq to fix it.
> I saw a same error in mailing list but not sure if it's the same problem:
> http://activemq.2283324.n4.nabble.com/Getting-a-quot-Cannot-publish-to-a-deleted-Destination-quot-but-eventually-works-after-a-couple-of-rs-td4682497.html



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message