activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-5237) Link stealing doesn't work for MQTT + Webscokets
Date Mon, 18 Aug 2014 21:45:19 GMT

    [ https://issues.apache.org/jira/browse/AMQ-5237?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14101365#comment-14101365
] 

Timothy Bish commented on AMQ-5237:
-----------------------------------

On the WS and WSS transports you need to add the allowLinkStealing=true option to the TransportConnector
URI

> Link stealing doesn't work for MQTT + Webscokets
> ------------------------------------------------
>
>                 Key: AMQ-5237
>                 URL: https://issues.apache.org/jira/browse/AMQ-5237
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: MQTT
>    Affects Versions: 5.10.0
>         Environment: Java 7 , Windows server 2012 or Ubuntu 12.04
>            Reporter: Surf
>            Assignee: Timothy Bish
>            Priority: Critical
>              Labels: mqtt, websocket
>             Fix For: 5.11.0
>
>
> Link stealing with existing clientid doesn't work for MQTT WS.
> As per MQTT definition, same clientID should replace existing connection.
> Simple testing: 
> Connect with MQTT WS client library ( Eclipse Paho JS) and connect-disconnect multiple
times. 
> It will give error of client already connected. 



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message