activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hiram Chirino <hi...@hiramchirino.com>
Subject Re: JDK requirements for 5.11?
Date Wed, 09 Jul 2014 13:23:21 GMT
+1 lets require Java 7

On Tue, Jul 8, 2014 at 4:47 PM, Daniel Kulp <dkulp@apache.org> wrote:
>
> Has there been a discussion and/or agreement about the Java requirements for 5.11?  5.10
still support Java6.  For 5.11, would it make sense to require Java7?
>
> I’m mostly asking as I have a pull request coming that updates all the poms and such
so that you can pull activemq into eclipse via M2E instead of the eclipse:eclipse thing. 
However, there is one small issue around activemq-runtime-config that causes a problem if
Eclipse is running with Java7, but the project level is Java6.  I *may* be able to work around
it, but it’s not work spending the time if the plan is to update to Java 7 anyway.
>
> Thoughts?
>
> --
> Daniel Kulp
> dkulp@apache.org - http://dankulp.com/blog
> Talend Community Coder - http://coders.talend.com
>



-- 
Hiram Chirino
Engineering | Red Hat, Inc.
hchirino@redhat.com | fusesource.com | redhat.com
skype: hiramchirino | twitter: @hiramchirino

Mime
View raw message