activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <>
Subject [jira] [Commented] (AMQ-5250) temp queue not working after long run of activemq
Date Mon, 30 Jun 2014 16:18:24 GMT


Timothy Bish commented on AMQ-5250:

A JUnit test case to demonstrate the issue is needed to understand the use case. 

> temp queue not working after long run of activemq
> -------------------------------------------------
>                 Key: AMQ-5250
>                 URL:
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 5.9.0
>            Reporter: Rural Hunter
> We encounterred a problem when using temp queue for request/reply pattern. It worked
normally but after a long time lets say several weeks, the applications using temp queue started
to report errors:
> 2014-06-25 08:25:59 [WARNING] Message back to the server fails´╝ü
> javax.jms.InvalidDestinationException: Cannot publish to a deleted Destination: temp-queue://ID:myserver-45345-1403492084155-1:1:259
> at org.apache.activemq.ActiveMQSession.send(
> at org.apache.activemq.ActiveMQMessageProducer.send(
> at org.apache.activemq.ActiveMQMessageProducer.send(
> at org.apache.activemq.ActiveMQMessageProducerSupport.send(
> I created a test application to test the temp when the problem happened and found this:
On each connection, the temp queue worked once and the second time it failed. I also tried
to monitor messages in ActiveMQ.Advisory.TempQueue. But I could only receive one message after
I subsribed on it everytime. 
> I checked the activemq log and there was nothing about the problem. Other applications
not using temp queue worked fine. This happened twice in recent month. I just had to restart
activemq to fix it.
> I saw a same error in mailing list but not sure if it's the same problem:

This message was sent by Atlassian JIRA

View raw message