activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-5225) broker will not start when using leveldb
Date Thu, 12 Jun 2014 19:13:02 GMT
John created AMQ-5225:
-------------------------

             Summary: broker will not start when using leveldb
                 Key: AMQ-5225
                 URL: https://issues.apache.org/jira/browse/AMQ-5225
             Project: ActiveMQ
          Issue Type: Bug
          Components: activemq-leveldb-store
    Affects Versions: 5.10.0
         Environment: Centos 6.3
            Reporter: John


I've configured a 3 node activemq cluster using this as my guide: http://activemq.apache.org/replicated-leveldb-store.html

1) Startup activemq on 1st node.
2) Startup activemq on 2nd node

     At this point I see a log message on the 1st node stating it was promoted to master.
 Next I see this Exception and am unable to connect to the broker.  Each time an activemq
instance is promoted to master, this exception occurs and broker is left unusable.


java.io.IOException: com.google.common.base.Objects.firstNonNull(Ljava/lang/Object;Ljava/lang/Object;)Ljava/lang/Object;
	at org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:39)[activemq-client-5.10.0.jar:5.10.0]
	at org.apache.activemq.leveldb.LevelDBClient.might_fail(LevelDBClient.scala:552)[activemq-leveldb-store-5.10.0.jar:5.10.0]
	at org.apache.activemq.leveldb.LevelDBClient.replay_init(LevelDBClient.scala:657)[activemq-leveldb-store-5.10.0.jar:5.10.0]
	at org.apache.activemq.leveldb.LevelDBClient.start(LevelDBClient.scala:558)[activemq-leveldb-store-5.10.0.jar:5.10.0]
	at org.apache.activemq.leveldb.DBManager.start(DBManager.scala:648)[activemq-leveldb-store-5.10.0.jar:5.10.0]
	at org.apache.activemq.leveldb.LevelDBStore.doStart(LevelDBStore.scala:235)[activemq-leveldb-store-5.10.0.jar:5.10.0]
	at org.apache.activemq.leveldb.replicated.MasterLevelDBStore.doStart(MasterLevelDBStore.scala:110)[activemq-leveldb-store-5.10.0.jar:5.10.0]
	at org.apache.activemq.util.ServiceSupport.start(ServiceSupport.java:55)[activemq-client-5.10.0.jar:5.10.0]
	at org.apache.activemq.leveldb.replicated.ElectingLevelDBStore$$anonfun$start_master$1.apply$mcV$sp(ElectingLevelDBStore.scala:226)[activemq-leveldb-store-5.10.0.jar:5.10.0]
	at org.fusesource.hawtdispatch.package$$anon$4.run(hawtdispatch.scala:330)[hawtdispatch-scala-2.11-1.21.jar:1.21]
	at java.lang.Thread.run(Thread.java:744)[:1.7.0_51]
2014-06-12 19:02:32,350 | INFO  | Stopped LevelDB[/opt/apache-activemq-5.10.0/bin/linux-x86-64/../../data/leveldb]
| org.apache.activemq.leveldb.LevelDBStore | LevelDB IOException handler.




--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message