activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tamas Cserveny (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMQ-5204) Embedded ActiveMQ with resource adapter disables SSL of JBoss 7
Date Mon, 02 Jun 2014 16:19:02 GMT
Tamas Cserveny created AMQ-5204:
-----------------------------------

             Summary: Embedded ActiveMQ with resource adapter disables SSL of JBoss 7
                 Key: AMQ-5204
                 URL: https://issues.apache.org/jira/browse/AMQ-5204
             Project: ActiveMQ
          Issue Type: Bug
          Components: Broker
    Affects Versions: 5.9.1
         Environment: JBoss 7.3.1
            Reporter: Tamas Cserveny


Hi All,

I tried to embed activemq-rar into JBoss 7.3.1 with SSL support enabled.
The SSL support is configured and working ok (I can connect without any problems) until the
first MDB initializes the embedded broker. After that moment the SSL stops working. It seems
that ActiveMQ broker reinitializes the platform SSL which in turn stops working. :/

This is how I did SSL support:
{quote}
<subsystem xmlns="urn:jboss:domain:web:1.5" default-virtual-server="default-host" native="false">
...
            <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https"
secure="true">
                <ssl name="https" password="changeit" certificate-key-file="../standalone/configuration/server.keystore"/>
            </connector>
{quote}

This is the broker URL used: vm://localhost?brokerConfig=xbean:broker-config.xml





--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message