activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Bish (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (AMQ-4812) Rebalance not working on 5.8.0
Date Tue, 03 Jun 2014 14:23:01 GMT

     [ https://issues.apache.org/jira/browse/AMQ-4812?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Timothy Bish closed AMQ-4812.
-----------------------------

    Resolution: Incomplete

No test case provided that demonstrates an actual issue with this functionality.  The unit
tests show things are currently working as expected.

> Rebalance not working on 5.8.0
> ------------------------------
>
>                 Key: AMQ-4812
>                 URL: https://issues.apache.org/jira/browse/AMQ-4812
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Transport
>    Affects Versions: 5.8.0
>            Reporter: Wayne Evans
>         Attachments: (Example)IsecStateConsumer.properties, Broker1_activemq.xml, Broker2_activemq.xml
>
>
> Two brokers networked.
> Transport connectors configured on both with:
> rebalanceClusterClients="true" updateClusterClients="true" updateClusterClientsOnRemove="true"
> Clients configured with only Broker 1 in Failover string.
> Clients all connect to 1st Broker when starting up.
> When first broker is stopped all clients fail over to 2nd Broker.
> When 1st Broker is brought back up all clients remain on 2nd Broker.
> Config files from both Brokers and one sample client config attached.
> Related issue - queued messages on 1st Broker that were passed from 2nd broker initially
are not consumed after 1st Broker is brought back up as rules prevent them from being passed
back to 2nd Broker where client consumers are attached.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message